
FLOWBLADE
INTRODUCTION

Flowblade Movie Editor is a multitrack non-linear video editor for Linux.

With Flowblade Movie Editor you can compose movies from video clips,
audio clips and graphics files. Clips can be cut at the desired frames, filters
can be added to clips, and you can create multilayer composite images using
compositor objects.

Flowblade offers a configurable workflow - toolset, its order, default tool and
certain timeline behaviours are user settable.

BASIC EDITING

This section describes the minimal workflow for making a movie using only
a single track.

Creating a New Project
Adding and removing new Sequences
Working with Media Files
Working with Bins
Using Timeline
Scrolling Timeline
Zooming Timeline
Changing Current Frame
Changing Current Frame when Clip is displayed on Monitor
Switching between Timeline and Clip Display
Setting Active Tracks
Effects of Track Active State
Selecting single clip
Selecting multiple clips on the same track
De-selecting all clips
Adding clips to Sequence
Drag'n'Drop
From Monitor
Editing Clips on Timeline
Trimming Clips



Moving Clips
Cutting Clips
Deleting Clips
Rendering Movie
Selecting Parameters
Rendering output

CREATING A NEW PROJECT

Flowblade Movie Editor saves work in project files.

To create a new Project:

Menu: Select File -> New from menu.
Keyboard Shortcut: Press Control+N.

A project contains:

one or more Sequences of edited media
a collection of Media Files stored in Bins.

There are two parameters that can be selected for a new project:

Project Profile Project Profile determines frame rate per second, image size in
pixels and pixel aspect ratio.
Tracks count Select the number of video and audio tracks that are used in the
project. This can be changed later, but the operation destroys the Undo / Redo
stack and all the Timeline Clips that do not fit in the newly created version of
the Sequence.

Video material is internally scaled to profile dimensions, so selecting Project
Profile with smaller pixel dimensions than the rendered output leads to de-
creased quality.

Flowblade Movie Editor handles image data internally as YUV420 frames,
so the encoding associated with a given profile has no affect on quality be-
fore rendering.

For best possible quality the input material, Project Profile and Rendering
Profile should all have the same pixel dimensions and pixel aspect ratio.



ADDING AND REMOVING NEW SEQUENCES

A Project contains one or more Sequences. The term Sequence refers to the
full contents of the timeline forming a program, a movie.

For complex projects it is sometimes best to use multiple sequences for creat-
ing and managing different parts of the finished product.

Adding Sequences:

3 panel layout: Press Right Mouse popup menu on Sequences area and select
menu item Add New Sequence..

2 panel layout: Press Right Mouse popup menu in the Project tab Sequences
area and select menu item Add New Sequence.

Or select Project -> Sequence -> Add New Sequence from application menu.

Deleting Sequences can be done with menu actions accessed in the same
places.

When creating a new Sequence, you can choose the number of Tracks in the
Sequence. This can be changed later, but the operation destroys the Undo /
Redo stack and all the Timeline Clips that do not fit in the newly created
version of the Sequence.

WORKING WITH MEDIA FILES

Flowblade Movie Editor holds files in Media tab. Files are listed in unnamed
table that displays contents of the currently selected Bin. Bins are listed in the
Bins table.

Opening Media Files:

Press Right Mouse on Media tab empty area and select menu item Add Vid-
eo, Audio or Image....

Or select Project -> Add Video, Audio or Image... from application menu.

Use dialog to find and select files.



Files are displayed as thumbnails.

Note that creating thumbnails for opened files will take some time.

PROJECT MEDIA: ABSOLUTE AND RELATIVE PATHS

Flowblade saves references to media files used in a project as absolute paths.
If a media is not found on load, Flowblade attempts to find a media file with
the same name in subfolders relative to the project file.

If all media used by a project is saved in subfolders relative to project file,
project file and media can moved as a unit and the project will load success-
fully after data is copied to a different place

Rendered files like transitions are saved by default in a hidden folder /.flow-
blade/rendered_clips/.

Menu item File->Save Backup Snapshot... saves project file, all media and
rendered files in a single folder that can saved as unit and and project can
always be loaded using this data

Load order between absolute and relative paths can be set in preferences
window

Media Relinker tool can be used to fix problems that may occur

NOTE: Information given here only applies to version 0.18 and above.

WORKING WITH BINS

In video editing a bin is a named location for storing media. The term is used
in Avid and was earlier used by film editors.

Adding a Bin:

3 panel layout: Press Right Mouse on Bin area to launch a popup menu and
select menu item - Add Bin.

2 panel layout: Press Right Mouse in the Media tab Bins panel to launch a
popup menu and select menu item - Add Bin.



Or select Project -> Bin -> Add Bin from application menu.

Deleting a Bin: Delete actions can be accessed from the same places as
above.

Renaming a Bin: Click on the Bin name, type new name and press Enter.

Moving files to another Bin:

Select and drag files on top of the Bin you wish to move the files into.

Select files and open Hamburger menu in Media panel and select menu item

Move Selected media to Bin and then the menu item with the Bins name.

USING TIMELINE

SCROLLING TIMELINE

Press and Drag Scrollbar below Timeline

Scroll Mouse Middle button + CTRL key while on top of Timeline

ZOOMING TIMELINE

Click Zoom In, Zoom Out or Zoom Length buttons.

Scroll Mouse Middle button on top of Timeline

CHANGING CURRENT FRAME

Drag with Right Mouse button starting from an empty space in the Timeline.

Drag with Left Mouse button on the Frame Scale.

Drag with Left Mouse on the Monitor Position Bar.

Click Left Arrow key or Right Arrow key to move to next or previous frame.

Click Up Arrow key or Down Arrow key to move to next or previous cut on



topmost active track.

Click Next or Prev button in Monitor Buttons area to move to next or
previous frame.

CHANGING CURRENT FRAME WHEN CLIP IS DISPLAYED ON
MONITOR

Drag with Left Mouse on the Monitor Position Bar.

Click Left Arrow key or Right Arrow key to move to next or previous frame.

Click Up Arrow key or Down Arrow key to move to next or previous of the
following:

Mark In/Mark Out/Start/End

Click Next or Prev button in Monitor Buttons area to move to next or
previous frame.

SWITCHING BETWEEN TIMELINE AND CLIP DISPLAY

Click buttons with icons representing sequence or single clip in Monitor
Buttons area.

Drag Media File on top of Monitor to display Clip.

SETTING ACTIVE TRACKS

Click Track Active Switch on the right side of Tracks Column area.

Top most Track Active Switch displays arrow pointing downwards indicating
that Insert From Monitor and other buttons place clips on that track.

EFFECTS OF TRACK ACTIVE STATE

Cuts are only performed on active Tracks.

Inserting Media File that is currently displayed in Monitor using Insert From
Monitor,



Append From Monitor or 3-Point Ovewrite buttons places clip on the top
most active Track indicated by arrow icon.

SELECTING SINGLE CLIP

Click on a clip with Left Mouse button.

SELECTING MULTIPLE CLIPS ON THE SAME TRACK

Click on a clip with Left Mouse button.

Click on another clip on the same track with Control + Left Mouse button.

All clips between clicked clips will be selected.

DE-SELECTING ALL CLIPS

Click on Timeline area background.

ADDING CLIPS TO SEQUENCE

DRAG'N'DROP

Press on a Media File in Media tab and drag it on top of the track you want to
place it on.

If 'Always Overwrite Blanks' is selected as preference for drag'n'drop action:

Clip will overwrite available blank and empty space and will perform insert
for the length of frames that would be overwritten.

If 'Overwrite blanks on non-V1 tracks' is selected as preference for
drag'n'drop action:

On track V1 clip will be inserted on the track at the nearest cut.

On non-V1 tracks:.

Clip will be inserted if dropped on a clip.



Clip will overwrite available blank and empty space and will perform insert
for the length of frames that would be overwritten.

If 'Always Insert' is selected as preference for drag'n'drop action:

Clip will be inserted on the track at the nearest cut.

FROM MONITOR

Open clip in Monitor by either:
double clicking on thumbnail icon,
dragging Media File on top of Monitor or
selecting Open in Clip Monitor item from Right Mouse context menu.
Select insert range

Use Mark In and Mark Out buttons to select range.

Use I an O keys to set to select range.

If range is not set, then the full clip length will be inserted.

Press Insert From Monitor button

Clip will be inserted on the first active track at the cut nearest of the currently
displayed frame.

First active track is marked by down arrow in the track Active Switch.

EDITING CLIPS ON TIMELINE

Once you have placed clips on the Timeline to form a Sequence, you will
probably need to refine the cuts between clips.

TRIMMING CLIPS

Use Trim Tool, Roll Tool, Slip Tool or Multitrim Tool.

MOVING CLIPS

Use Insert Tool, Move Tool, Spacer Tool or Box Tool.



CUTTING CLIPS

Select cut frame

Cut is always made before the currently displayed frame on all active tracks.

Cut clip

Press Cut button or press X on the keyboard.

DELETING CLIPS

Splice Out:

Select clip(s) and press Delete key or use the Splice Out button on middle
bar.

All the clips in the track after the deleted clip(s) are moved to left to cover the
created empty space.

Lift: Select clip(s) and press the Lift button on the middle bar.
Clip is replaced with a blank if it is in middle of track.
Other clips on the track are not moved.

Ripple Delete:

Select clip(s) and press the Ripple Delete button on middle bar.

All the clips on all tracks are moved forward to cover the created empty
space.

If moving clips backwards would cause an overwrite to happen on timeline,
edit is not allowed.

Range Delete: Set Mark In and Mark out on timeline and and press the Range
Delete button on middle bar. All the clips and blanks on all tracks are deleted
between marks and everything after deleted range is moved forward the
length of the deleted range.

Fade/Transition cover delete: Select a single rendered fade or transition clip



and press Delete key or button. If clips before and after of the deleted clip
have frames available, then the space left by the deleted clip will covered
using material from adjacent clips. If material is not available a splice out
will be performed. A preference exists to always perform splice out on fades
and transitions.

Use Keyboard Shortcuts! It is much faster to use X key to cut clips and
Delete key to splice out clips than it is to use buttons for the same operations.

RENDERING MOVIE

SELECTING PARAMETERS

Folder File Select button selects folder to place the rendered file.
Name entry widget provides means to set the name of the output file.
Use Encoding Format and untitled Quality drop down menus make to select
the type of file to be rendered.

RENDERING OUTPUT

Press Render Button to begin rendering.
A Render Window will open displaying information on file path of render
file, estimated time left, render time and a Progress bar widget.
After rendering is complete, Render Window will close automatically.

EDIT TOOLS AND WORKFLOW

Flowblade Movie Editor has 10 edit tools, 4 move tools, 4 trim tools and Cut
tool and Keyframe tool .

Workflow configuration
Workflow presets
Managing tool set
Setting timeline behaviours
Selecting Tools
Move Tools
Insert
Move
Spacer
Box



Trim Tools
Trim
Roll
Slip
Ripple Trim
Multitrim
Other Tools
Cut
Keyframe

WORKFLOW CONFIGURATION

Flowblade offers a configurable workflow with user selectable toolset and
timeline behaviours.

Worflow is configured from the menu launched by pressing icon .

You can select 9 tools to be available and set the order the tools presented in
with the first one being the default tool.

You can also further configure the workflow by selecting the drag and drop
action, and make Compositors automatically follow their origin clips.

There are 2 preset workflows available.

WORKFLOW PRESETS

STANDARD

Standard workflow has the Move tool as default tool and presents a workflow
similar to most video editors.

Tools: Move, Multitrim, Spacer, Insert, Cut, Keyframe.

Behaviours: Drag'n'Drop: 'Always Overwrite Blanks' , Compositors Autofol-
low: Off



FILM STYLE

Film Style workflow has the Insert tool as default tool and employs insert
style editing. This was the workflow in previous versions of the application.

Tools: Insert, Move, Trim, Roll, Slip, Spacer, Box.

Behaviours: Drag'n'Drop: 'Overwrite blanks on non-V1 tracks' , Compositors

Autofollow: Off

MANAGING TOOL SET

Launch Workflow popup menu clip

Press icon.

Turn tools on and off

Click Tool name -> Tool Active check menu item

Set tool position

Click Tool name -> Sert Position -> Position number menu item

SETTING TIMELINE BEHAVIOURS

Worflow is configured from the menu launched by pressing icon .

Launch Workflow popup menu clip

Press icon .

Set drag'n'drop behaviours in submenu Behaviours -> Drag'n'Drop Action

If 'Always Overwrite Blanks':

Clip will overwrite available blank and empty space and will perform insert
for the length of frames that would be overwritten.



If 'Overwrite blanks on non-V1 tracks':

On track V1 clip will be inserted on the track at the nearest cut.

On non-V1 tracks:

Clip will be inserted if dropped on a clip.

Clip will overwrite available blank and empty space and will perform insert
for the length of frames that would be overwritten.

If 'Always Insert':

Clip will be inserted on the track at the nearest cut.

Set Compositor behaviour with check item Compositor Autofollow

Select Compositing mode for new Sequences with Behaviours ->

New Sequence Default Compositing Mode

SELECTING TOOLS

Use Tool Switcher button drop menu or press key 1 - 9 to pick tool .

Use Keyboard Shortcuts! It is much faster to use keys 1 - 9 to change tools.

Note that keys 1-9 only change tools if timeline has keyboard focus.

MOVE TOOLS

INSERT

Splice out one or more clips and insert them at desired cut on any track.

Select clip

Click Left Mouse on a clip.

Select other end of clip range if moving multiple clips



Click CTRL+Left Mouse on the clip you wish to be the other end of move
clip range.

Drag Clip(s) to new position

Press Left Mouse on a selecetd clip and drag clip/s to a new position.

Yellow arrow displays insert point.

You can also move clips to a different track.

Drag clip ends to change clip length.

Place cursor near clip end

When cursor changes to horizontal arrow with vertical bar you can start clip
end drag edit.

Drag clip end with Left Mouse.

Added clip length will perform overwrite on blanks and empty space

Added clip length will perform insert on other clips

Decreased clip length will perform splice out.

MOVE

Lift out one or more clips and insert them at any point to overwrite on any
track.

Select clip

Click Left Mouse on a clip.

Select other end of clip range if moving multiple clips

Click CTRL+Left Mouse on the clip you wish to be the other end of move
clip range.



Drag Clip(s) to new position

Press Left Mouse on a selecetd clip and drag clip/s to a new position.

Red shadow clips show overwrite area.

You can also move clips to a different track.

Drag clip ends to change clip length.

Place cursor near clip end

When cursor changes to horizontal arrow with vertical bar you can start clip
end drag edit.

Drag clip end with Left Mouse.

Added clip length will perform overwrite on blanks and empty space

Added clip length will perform insert on other clips

Decreased clip length will perform splice out.

Select and overwrite move all Timeline items contained in a box selection.

Select an area on Timeline by dragging a box selection with Left Mouse
around all items you wish to move and release mouse button.

Press Left Mouse inside the box selection and drag the box into new position
on timeline and release mouse.

Box contents are overwritten on new position and Compositors are moved.

SPACER

Move all Timeline items after pressed frame on all tracks or on a single track

Select a clip on Timeline and move it and all items to the right of it

Press Left Mouse on a clip.



Continue to Left drag clip and all clips and compositors to right of it into a
new position

It is not possible to move items on top of clips. Items can only be moved on
top of empty space

Use Control button to only affect items on a single track

Press Control and use Left Mouse to move all items on single track to the
right of the selected clip

BOX

Select and overwrite move all Timeline items contained in a box selection.

Select an area on Timeline by dragging a box selection with Left Mouse
around all items you wish to move and release mouse button.

Press Left Mouse inside the box selection and drag the box into new position
on timeline and release mouse.

Box contents are overwritten on new position and Compositors are moved.

TRIM TOOLS

TRIM

Make clip longer or shorter from either clip's end or from clip's beginning.

Select trimmed cut and select new in or out frame

Press with Left Mouse on a clip near the side you wish to trim

Cursor change indicates the side of cut that will be trimmed.

Continue on to Left drag on clip to select new in or out frame

View trimmed cut

Press Play button to loop view edit. Exiting trim tool allows free playback.



ROLL

Move edit point between two clips so that their combined length stays the
same.

Select trimmed cut and select new in or out frames

Press with Left Mouse on a clip near the cut you wish to trim on the side you
wish to view while trimming

Continue on to Left drag on the two selected clips to select in or out frames
for both clips

Select new trim from another clip

Click on empty space on the Timeline

Click with Left Mouse near the cut you wish to trim

View trimmed cut

Press Play button to loop view edit. Exiting trim tool allows free playback.

SLIP

Change the displayed area of media in a clip while keeping the clip position
unchanged on the timeline.

Select trimmed clip and change displayed media

Press with Left Mouse on a clip you wish to slip trim

Continue on to Left drag from clip area to display different area of media

Select new trim from another clip

Click on empty space on the Timeline

Click with Left Mouse on the clip you wish to trim



View trimmed cut

Press Play button to loop view edit. Exiting trim tool allows free playback.

RIPPLE TRIM

Make clip longer or shorter from either clip's end or from clip's beginning
and move items on other tracks to maintain position sync with trimmed track.

Select trimmed cut and select new in or out frame

Press with Left Mouse on a clip near the side you wish to trim

Continue on to Left drag on clip to select new in or out frame

Items after trim point maintain position sync with trimmed track.

Trim range is limited so that no overwrites can happen on other tracks.

View trimmed cut

Press Play button to loop view edit. Exiting trim tool allows free playback.

MULTITRIM

Do Trim, Roll or Slip tool edits based on cursor position on timeline.

Cursor change indicates which type of trim edit is done when edit is initiated
with Left Mouse press.

If cursor is right on the cut, a Roll edit is done.

If cursor is right on the center of clip, a Slip edit is done.

On other cursor positions a Trim edit on the closer clip end is done.

Continue on to Left drag to complete the edit.

Press Play button to loop view edit. Exiting trim tool allows free playback.



OTHER TOOLS

CUT

Cut single or multiple clips.

Cut single clip.

Position cursor on the frame on the clip you wish to cut at and press
Left Mouse.

Cut clips on all tracks on selected position.

Position cursor on frame you wish to cut at and press Control + Left Mouse.

KEYFRAME

Edit Volume or Brightness filter keyfrmes on timeline.

Click on the clip you wish to edit.

A Volume filter is created automatically if clip does not have one.

A keyframe editor overlay is displayed on timeline.

Press and drag keyframe with Left Mouse to set its value and position

Press on empty on overlay area with Left Mouse to create and drag keyframe.

Delete key deletes the active keyframe.

Press on Hamburger menu icon to change to Brightness keyframe editing or
to access additional edit actions.

Press outside overlay area to close overlay editor.



CREATING COMPOSITED IMAGES

Flowblade Movie Editor uses Compositors to mix images from two different
tracks.

Compositing Modes
Top Down Free Move
Top Down Auto Follow
Standard Auto Follow
Standard Full Track
Standard Full Track Compositing Mode
Workflow
Standard Auto Follow Compositing Mode
Workflow

EXAMPLE:

All tracks need Compositors when creating compositions with more the 2
tracks Top Down Free Move Compositing mode Workflow

Compositor are executed from top to bottom in Top Down Compositing
modes

Rendering A Composited Frame

EXAMPLE:

Creating a 3-layer composite Media Items & desired result Gimp/Photoshop
style layer order yields wrong result Correct layer order when compositing
order is top-to-bottom

COMPOSITING MODES

The way that Compositors work is defined by a Compositing Mode. Users
can select Compositing Mode to suit their preference or editing needs of a
particular Sequence.

To set Compositing Mode for a Sequence select it from Sequence -> Compo-
siting Mode sub menu.



TOP DOWN FREE MOVE

This is the most powerful and complex Compositing Mode. Users can set
destination tracks and positions of Compositors freely and create node tree
compositions if needed.

TOP DOWN AUTO FOLLOW

Mode removed for 2.6.

STANDARD AUTO FOLLOW

Compositors follow their origin clips automatically and users can only add
one compositor per clip. All Compositors have track V1 as their destination
track. It is not possible to create node tree compositions.

STANDARD FULL TRACK

This is the most simple and easiest to use Compositing Mode. No Composi-
tors are needed. Fade In/Outs, Wipes and transforms are created with Filters.
Some compositing functionality is not available. It is not possible to create
node tree compositions

STANDARD FULL TRACK COMPOSITING MODE

Compositing in Standard Full Track mode is similar to using layers in
applications like Gimp and Photoshop. Compositing in Standard Auto Follow
mode happens in bottom to top order. No Compositors are used.

WORKFLOW

Add Clips on Timeline:

Images with alpha channel are composited in bottom to top order.

Controlling image opacity

Add Fade In or Fade Out Filters to create opacity transitions in the beginning
or end of Clip.



Add Wipe Filters on top clip to create wipe transitions.

Transforming image

Add Position Scale, Rotation or Shear filter.

STANDARD AUTO FOLLOW COMPOSITING MODE

Compositing in Standard Auto Follow mode happens in bottom to top order
like in Gimp and Photoshop. Compositors are used and they follow their
origin clips automatically.

On the Timeline a Compositor is displayed as a purple square with rounded
corners.

Parameters defining the resulting image are edited in the Compositors tab.

WORKFLOW

Creating a Compositor

Click Right Mouse on any clip on tracks from V5 to V2 and select for
example

Add Compositor -> Dissolve or Add Blender -> Softlight from popupmenu
to create a new Compositor.

Editing Compositor Parameters in Compositors Tab

Click Compositor with Left Mouse.

Click Right Mouse on any Compositor and select Open In Compositor Editor

Edit parameters using value editors.

Deleting Compositor

Click Left Mouse on any Compositor to select it and press Delete key.



EXAMPLE:

ALL TRACKS NEED COMPOSITORS WHEN CREATING

COMPOSITIONS WITH MORE THE 2 TRACKS

In this mode all Compositors have track V1 as their target target.

Because of this adding a Compositor to only the top track can make it
dissapper.

When composition has more then 2 tracks, all clips need to have
Compositors to get the expected result.

Only top track has Compositor

Clip on track V3 has Compositor which composites it on track V1. However,
the Clip on track V2 is on top of the composited image on track V1 and gets
displayed.

All tracks have Compositors

Images on all tracks are composited on track V1 to get the expected result.

TOP DOWN FREE MOVE COMPOSITING MODE

In these modes Compositors have a Source track and a Destination track.

On the Timeline a Compositor is displayed as a rectangular object on top of
two tracks. Source track is always the one above Compositor, but Destination
track may be any of the tracks below it.

Parameters defining the resulting image are edited in the Compositors tab.

WORKFLOW

By combining multiple tracks and multiple Compositors complex composite
images can be achieved.



Creating a Compositor

Click Right Mouse on any clip on tracks from V5 to V2 and select for
example

Add Compositor -> Dissolve or Add Blender -> Softlight from popupmenu
to create a new Compositor.

Trimmimg or Moving a Compositor

To trim Compositor start and end points:

Press and drag Left Mouse near either end of Compositor on Timeline.

To move Compositor:

Press and drag Left Mouse in the middle of Compositor on Timeline.

Editing Compositor Parameters in Compositors Tab

Double click Compositor with Left Mouse.

Click Right Mouse on any Compositor and select Open In Compositor Editor

Edit parameters using value editors.

Deleting Compositor

Click Left Mouse on any Compositor to select it and press Delete key.

COMPOSITOR ARE EXECUTED FROM TOP TO BOTTOM IN TOP

DOWN COMPOSITING MODES

In Flowblade Movie Editor the order of rendering is top-to-bottom, instead of
bottom-to-top like in Gimp or Photoshop. When attempting certain type of
multilayer composites this yields results that seem unintuitive, unless the user
is aware of rendering order of Compositors.



RENDERING A COMPOSITED FRAME

For each frame it is checked if there is a Compositor covering this frame on
the top most track.

If such Compositor is found, do composite on Destination track.

Frame on Destination track is now altered and if that frame is used as source
the altered version is used

Check if frame on next track below has compositor and if Compositor is
found render the composite image

This is done for each track.

Output image on is from the topmost track that has media on the frame and
does not have a compostor on the frame.

EXAMPLE: CREATING A 3-LAYER COMPOSITE

In this example we demonstrate how top-to-bottom Compositor order affects
compositing. We are trying to make word 'GO' apperar on top of 2-color
background made by combining red and blue Color Clips using 'Free Stripes'
wipe.

MEDIA ITEMS AND DESIRED RESULT

To make alpha transparency work the GO.PNG graphic has to composited
using 'Dissolve'.

Clips:

RED and BLUE Color Clips and GO.PNG graphic with alpha transparency

Desired result



GIMP/PHOTOSHOP STYLE LAYER ORDER YIELDS WRONG
RESULT

Here we have arranged clips on the tracks as we would arrange layers in
Gimp.

Gimp style layer order

What happens here is that first 'GO.PNG' is composited on 'RED' Color Clip,
and the resulting image is composited using 'Free Stripes' wipe on top of
'BLUE' Color Clip. We get the wrong result.

Wrong result

CORRECT LAYER ORDER WHEN COMPOSITING ORDER IS

TOP-TO-BOTTOM

Here we have arranged clips in correct order for the desired result.

Correct layer order

Here 'RED' Color Clip is first composited using 'Free Stripes' wipe on
'BLUE' Color Clip. After that 'GO.PNG' is composited on top of the resulting
image (that is already rendered on track V1) using 'Dissolve' to get final out-
put image.

Destination track in 'Region' Compositor is V1, Source track is V3

Desired result

FILTERING IMAGE AND AUDIO

In Flowblade Movie Editor you can add a Filters to all clips to modify output
image and audio.

Filter Workflow
Adding Filter
Opening Filter for Editing in Filters tab
Editing Filters



Cloning Filters from other Clips
Deleting Filters from Clips

FILTER WORKFLOW

ADDING FILTER

Click Right Mouse on any clip and select for example

Add Filter -> Blur -> Pixelize from popup menu.

In Filters tab: double click on a filter in the currently displayed filters group.

In Filters tab: drag a filter from the currently displayed filters group to the
Filters Stack table below.

OPENING FILTER FOR EDITING IN FILTERS TAB

Click Right Mouse on any clip and select Open in Filters Editor from popup
menu.

Double click on any clip.

EDITING FILTERS

Parameters defing output are edited in the Filters tab.

Clips will display small filter icon in the top right corner if a filter has been
added to them.

Clips will display grey filter icon in the center of the clip while clip is being
edited.

The filters that modify alpha channel only have effect if the clip they are
attached to is mixed with other clips using Compositors.



CLONING FILTERS FROM OTHER CLIPS

Click Right Mouse on any clip and select Clone Filters -> From Next Clip or

Clone Filters -> From Previous Clip from popup menu.

DELETING FILTERS FROM CLIPS

Select filter in Filters Stack table and click Delete button above.

Select filter in Filters Stack table and press Delete key.

Select clip or range of clips in Timeline and select Clear Filters from
application menu.

ADVANCED EDITING FEATURES

1. Advanced Project Actions

Combining Sequences

Split part of Sequence to new Sequence

Importing Media from another Project

2. Timeline Audio Syncing

3. Slow / Fast Motion and Reverse Clips

Creating Motion Clips

Creating Reverse Clips

4. Clip Parenting

Main points

Setting Sync Parent

Resyncing Sync Child Clips



Clearing Sync Parent Relations

Syncing Composited Clips

Audio Split Syncing

5. Timeline Rendering

Turning timeline rendering on

Timeline Render Modes

User actions:

Settings

6. Filter Masking

1. ADVANCED PROJECT ACTIONS

COMBINING SEQUENCES

It is possible to import full contents of another Sequence into Sequence
currently being edited.

Select Sequence->Import Another Sequence into this Sequnce...

Select Import action.

Append Sequence adds imported Sequence at the end of current Sequence

Insert Sequence at Playhead Position creates a cut at playhead position and
inserts imported Sequences at that position

Select a Sequence to Import

Note that you obivously need atleast two Sequences to exist to do any import
actions.

Press Import button to execute import.



SPLIT PART OF SEQUENCE TO NEW SEQUENCE

Select Sequence->Split to new Sequence at Playhead position

After confirmation dialog the a new Sequence with contents of source
Sequence after playhead position will be created and made active.

IMPORTING MEDIA FROM ANOTHER PROJECT

You can import Media Items from another Project.

Select Project->Import Media From Project...

Select a Project file from file system.

Media items that are not present in current Project will be opened in the
current bin. Note that it takes a few seconds to load the project before new
Media Items begin to appear.

2. TIMELINE AUDIO SYNCING

You can make a clip to move to a position in timeline in which its audio is in
sync with audio of another clip on timeline.

This enables you to do simplified version of multicam editing on the
timeline.

Open context menu with Right Mouse on Clip you wish to sync with some
other clip.

Select menu item Select Clip to Audio Sync With.... The cursor changes to a
targeting cross.

Click on Clip you wish to audio sync with.

A dialog opens giving info on the sync action that is to be done to sync clips.

Press - Do Audio Sync Move Edit button to do the syncing edit.

It is usually a good idea to mute one of the synched clips



Audio synching looks for best matemathical match between two audio
waveforms, so audio syncing non-matching audio will produce random
results.

3. SLOW / FAST MOTION AND REVERSE CLIPS

In Flowblade motion effects are achived by rendering slow / fast motion or
reverse versions of video clips and placing those on the timeline.

CREATING MOTION CLIPS

Right click on a Media File and select Render Slow / Fast Motion File from
menu

Edit parameters for the new motion Clip

Set speed

Give name and location for motion Clip

Select rendering parameters for motion Clip. It is probably a good idea to use
a lossless format here to avoid any generational quality losses.

Select render range, either:

Full Source Clip

From Source Clip Mark In to Mark Out

Click Render button to create a new motion Clip

CREATING REVERSE CLIPS

Right click on a Media File and select Render Reverse Motion File from
menu

Edit parameters for the new motion Clip

Set speed



Give name and location for reverse Clip

Select rendering parameters for reverse Clip. It is probably a good idea to use
a lossless format here to avoid any generational quality losses.

Select render range, either:

Full Source Clip

From Source Clip Mark In to Mark Out

Click Render button to create a new reverse Clip

4. CLIP PARENTING

In Flowblade Movie Editor you can set a clip's positions to follow another
clip's positions on request.

MAIN POINTS

Sync relations are set up by selecting a Sync Parent Clip for a Sync Child
Clip.

Only clips on track V1 can be Sync Parent Clips. This is done to encourage
edit style in which the main body of the Sequence is on track V1 and
composites and audio split edits are done relative to the clip sequence on
track V1.

Sync feature helps preserve earlier work an multitrack composites and audio
split edits when clips are no longer in correct positions relative to each other,
because of edits elsewhere on the Sequence.

Resyncs are only done on request to avoid jumping of clips on the timeline
while editing. Explicit resyncs are also better from the point of view of avoid-
ing side effects when doing edits.



SETTING SYNC PARENT

Click Right Mouse on clip and select Select Sync Parent Clip... on any clip
NOT on track V1.

Cursor turns into a Target Cross. Click on clip on track V1 to select it as Sync
Parent Clip.

Sync Relation is established between the two clips. Cursor turns back into a
default pointer.

Sync State Stripe appers on the Sync Child Clip. Sync State Indicator Stripes
on Clips:

Green means that clip is in sync with parent.

Red means that clip is NOT in sync with parent.

Gray means that Sync Parent Clip is no longer on track V1.

RESYNCING SYNC CHILD CLIPS

Select Edit - >Resync Selected to resync from application menu selected

Sync Child Clips.

Click Right Mouse on Sync Child Clip and select Resync from popoup menu
to resync single clip.

Press Resync Selected Bbtton to resync selected Sync Child Clips.

CLEARING SYNC PARENT RELATIONS

Click Right Mouse on Sync Child Clip and select Clear Sync Relation.

SYNCING COMPOSITED CLIPS

If appropriate set all clips that are part of a multitrack composite synched to
the same clip.



AUDIO SPLIT SYNCING

Click Right Mouse on clip in track V1 and select Split Audio Synched.

Edit audio split using Two Roll Trim mode to maintain sync with parent clip.

Resync Audio as needed.

5. TIMELINE RENDERING

Timeline rendering is way to achieve smooth playback on areas of timeline
that place to heavy demands on system resources for acceptable playback.

TURNING TIMELINE RENDERING ON

There are two places user can swicth timeline rendering on

Menu in bottom left corner.

Menu item Sequence->Timeline Rendering.

Timeline render menu launcher at left, rendered and unrendered range shown
on Timeline Render Control Strip.

TIMELINE RENDER MODES

User can select from two different modes when activating timeline rendering.

Render Auto. In this mode defined ranges are rendered automatically if time-
line content in range changes.

Render On Request. In this mode renges are renderd on user request.

USER ACTIONS

Creating render range. Drag with Mouse Left on Timeline Render Control
Strip to create new range.

Making render range bigger. Drag with Mouse Left on Timeline Render
Control Strip from center over one side to make range larger in that direction.



To make range larger on both sides drag over current full range.

Combining render ranges. Drag with Mouse Left over multiple ranges.

Deleting render ranges. Click on range to select it and press Delete key or
click with Mouse Right on Timeline Render Control Strip and select item
from menu to delete range.

Requesting render in Mode 'Render On Request'. Double click on render
range or click with Mouse Right on Timeline Render Control Strip and select
item from menu render range.

SETTINGS

Timeline rendering encoding can be selected from Sequence->Timeline
Rendering->Settings.

6. FILTER MASKING

Filter masking allows for one or more filters to be applied only on some user
defined part of image.

Filter masking menu launch button above 'Add Filter Mask' tootip, Mask -
Begin and Mask - End filters defining which filters are masked, on the right
image with masked Sepia filter.

Click Filter Mask Menu launch button and select if you wish to apply mask
on one or all filters.

In submenu select between Alpha Shape and Luma Key masks.

Edit mask parameters in filter edit panel for Mask - Begin filter.

You can drag and drop filters in and out of the masked range of filter stack.



RANGE LOG

Flowblade provides functionality save, name and manage in point to out
point ranges on media items.

Rationale
Creating Range Log Items
With Clip Monitor
Drag'n'Drop from Timeline
Adding Range Log items to Timeline
With buttons
Drag'n'Drop into Timeline
Managing Range Log Items

RATIONALE

This functionality is mainly useful then there are media items that contain
multiple areas of interest or if the user wants to save in and out points of an
edit for later use.

A typical example use case for the feature would be:

User has a long clip of a speech delivered at some social function, congress,
company event, etc.

User wants to mark and name the interesting parts of the speech

CREATING RANGE LOG ITEMS

WITH CLIP MONITOR

Add Media Item to Clip Monitor

Set Mark In and Mark Out points

Press 'Log Current marked Range' -button on the bottom left in the Range
Log panel



DRAG'N'DROP FROM TIMELINE

Drag a Clip from Timeline on top of Items list view in the Range Log panel

ADDING RANGE LOG ITEMS TO TIMELINE

WITH BUTTONS

Press 'Append displayed..." -button on the bottom right corner to append all
Items as Clips on active Track

Press 'Insert selected..." -button next to bottom right corner button to insert
all selected Items on active track at nearest cut from the currently displayed
Timeline position

DRAG'N'DROP INTO TIMELINE

Select a Range Log item and drag it into the desired position on Timeline

MANAGING RANGE LOG ITEMS

Use top row drop down menu to select the displayed Items Group

Use the top left corner button drop down menu to create, rename and delete
Items Groups

PROXY EDITING

Proxy editing is a method of editing in which original media clips are
presented on timeline by proxy clips.

Rationale
Generic Proxy Editing workflow
Flowblade proxy editing
Important notes about Flowblade proxy editing



RATIONALE

There are two main reasons to use proxy editing:

Original media from which the program is edited makes too high demands
for either disk bandwidth or CPU processing power for decoding to enable
responsive editing

Original is kept on network server, slow external disk or other media with
restricted access and does not enable provide responsive editing if accessed
directly.

GENERIC PROXY EDITING WORKFLOW

All proxy editing workflows have the same phases:

Render proxy media from original media

Replace original media with proxy media

Edit using proxy media

Replace proxy media with original media

Render final program using original media

FLOWBLADE PROXY EDITING

Creating Proxy Media:

Select Project->Proxy Manager in menu and set proxy file settings in
Proxy Encoding area

Select Video Media files in 'Media' Panel

Press button with proxy file icon next Delete button in 'Media' Panel

If Project is already in 'Using Proxy Media' proxy mode, timeline clips with
original media that had proxy media rendered to will be replaced with proxy
media immediately



Converting to use Proxy media

Select Project->Proxy Manager to open Proxy Manager

Press Use Proxy Media button

Editing with proxy media

Clips that use proxy media have a blue stripe indicating that status

A proxy editing indicator icon is displayed at left bottom corner If new proxy
media is rendered timeline clips using the original media in question will be
replaced with proxy media immediately Project can be saved normally and
converted after load to use original media Converting to use Original Media

Select Project->Proxy Manager to open Proxy Manager

Press Use Original Media button

IMPORTANT NOTES ABOUT FLOWBLADE PROXY EDITING

DESTROYING ANY MEDIA while doing proxy editing

WILL PREVENT

CONVERTING BACK TO USING ORIGINAL MEDIA

It is only possible to use all existing proxy media and clips or all original
media. It is not possible to use only some of the created proxy media.

Flowblade uses a programming techique that changes the paths used by
media items and clips to point either to hidden proxy media or original
media.

Changing from one to another is implemented by writing a hidden temporary
project file to disk and replacing paths when project is read back. Because of
this any missing original media makes conversion back to using original
media fail.



CONTAINER CLIPS

Container Clips Concept
Components
Rationale
Workflow
Container Clip Types
G'Mic Script Container Clips
Components
Use Cases
Creating G'Mic Script Container Clips
Blender Project Container Clips
Components
Use Cases
Creating Blender Project Container Clips
Selection Container Clips
Components
Use Cases
Creating Selection Container Clip from Selection
Creating Selection Container Clip from Sequence
Creating audio synced Selection Container Clip from two Media Items
Creating Editable Blender Container Programs
Editable Objects
Editors

Example

Step 1: Find out object and attribute names using Blenders Script view

Step 2: Edit Container Program Edit Data

Step 3: Set values for timeline clips

Launch script



CONTAINER CLIPS CONCEPT

A Container Clip is a Media Item and the Timeline Clip made from it that has
three items packed together as a single entity: Program, Unrendered Media
and Rendered Media.

COMPONENTS

Unrendered Media This is what is displayed on timeline if container clip
media is not rendered.

Program This data is used to render a media clip on timeline, sometimes
using unrendered media as input.

Rendered Media This is what is displayed on timeline when Container Clip is
rendered.

RATIONALE

Performance:

Container Clips provide means to turn resource heavy media items such as
Sequence Clips into rendered media

Resource Management:

For example Blender Projects and G'Mic scripts are nicely managed by
having them available via Container Clips

Capablity extension:

Existing technologies and applications can made to provide functionality that
is not available otherwise. There will be more developments in this area in
the future.

Sharing:

In the future we will create a central repository to share container clip
resources.



WORKFLOW

Create Container Clip Media Item using Project -> Create Contaniner Clip
menu.

Edit properties of Container Clip with Right Mouse menu selection

Edit Container Data if available.

Add Container Clip on Timeline.

Render and manage Container Clips on Timeline with Right Mouse submenu
Container Clip Actions.

CONTAINER CLIP TYPES

G'MIC SCRIPT CONTAINER CLIPS

COMPONENTS

Unrendered Media Video Clip.

Program G'Mic script created and saved from G'Mic tool.

Rendered Media A clip rendered with G'mic effect.

USE CASES

Render G'Mic effects only on clip ranges used on timeline.

Make easier to use single user defined G'Mic effect on multple clips.

CREATING G'MIC SCRIPT CONTAINER CLIPS

Open G'Mic tool.

Create G'Mic effect script. See section on G'Mic Tool in Chapter Tools.

Press Save Script button in bottom left corner and save effect.



Select menu item Project -> Create Contaniner Clip -> From G'Mix Script.

Select the script you saved and the clip that it will be applied on to create
Container Clip.

BLENDER PROJECT CONTAINER CLIPS

COMPONENTS

Unrendered Media A placeholder Video Clip rendered on Media item
creation.

Program Project file with *blend extension.

Rendered Media Rendered Clipfrom project file.

USE CASES

Manage Blender projects by having handles for them in Flowblade.

Create editors for Blender projects so that users can edit their properies on
Flowblade

Make possible to contribute and shear interesting Blender Projects for e.g. so
nice text effects.

CREATING BLENDER PROJECT CONTAINER CLIPS

Open G'Mic tool.

Select menu item Project -> Create Contaniner Clip -> From Blender Project
and select Blender project file with .blend extension.

You can edit values that Blender project is rendered with, see section Edíting
Container Programs below.



SELECTION CONTAINER CLIPS

COMPONENTS

Unrendered Media A MLT XML vdieo clip created from selection or
sequence like Compound clips previously.

Program A MLT XML video clip created from selection or sequence like
Compound clips previously. Here Program is the same as unrendered media.

Rendered Media Clip Rendered from MLT XML Clip.

USE CASES

Make possible to create Media items from selections and full Sequences.

Give better timeline performance for complex multitrack container clips by
pre-rendering them on timeline.

CREATING SELECTION CONTAINER CLIP FROM SELECTION

Select 2 or more adjacent clips from a single track.

Select Project->Create Container Clip->From Selected Clips

CREATING SELECTION CONTAINER CLIP FROM SEQUENCE

Select Project->Create Container Clip->From Current Sequence

CREATING AUDIO SYNCED SELECTION CONTAINER CLIP
FROM TWO MEDIA ITEMS

Select 2 Media Items in Media panel.

The expected case is to select 1 Video and 1 Audio Clip.

If you select 2 Video Clips then which is used as video depends on selection
order.

Audio from clip treated as video is muted.



Select Project->Create Compound Clip->Audio Sync Merge Clip From 2
Media Items

If audio sync is successful a dialog appers. Give a name for the new Media
Item in the dialog.

A new Media Item appears in the current Bin.

Audio syncing looks for best matemathical match between two audio
waveforms, so audio syncing non-matching audio will produce random
results.

CREATING EDITABLE BLENDER CONTAINER PROGRAMS

It is possible to create and add editors to Blender Container Clips that allow
users to change the rendered output.

Feature uses Blender Python API and runs a script before output is rendered
to change attribute values of Blender scene objects.

This is an advanced feature and requires a working knowledge on scripting
using Blender's Python API.

EDITABLE OBJECTS

Three types of objects are currently availabe to be user edited using this
functionality.

Objects are bpy.data.objects objects available for Python scripts.

Curves are bpy.data.curves objects available for Python scripts.

Materials are bpy.data.materials objects available for Python scripts.

EDITORS

Five different types of editors are currently availabe for editing object
attributes.

String editor outputs a quoted string in the launch script.



Internal editor outputs an integer number in the launch script.

Float editor outputs a float number in the launch script..

Color editor outputs a sequence of 4 comma separated floats that define a
color.

Value editor outputs a non-quoted string in the launch script. that can be used
as value to any attribute.

EXAMPLE

In this example we create String and Color editors to change text and color
rendered from Blender Project file.

STEP 1:

FIND OUT OBJECT AND ATTRIBUTE NAMES USING BLENDERS
SCRIPT VIEW

Scene and sript panel from Blender with our test project open.

Here we have established that:

We need to edit object bpy.data.curves["Title1"] attribute body to set text
string.

We need to edit object bpy.data.materials["Title1.material"] attribute dif-
fuse_color to set text color.

STEP 2:

EDIT CONTAINER PROGRAM EDIT DATA

With this information we can create the editors that allow editing text and
color of clips rendered from this project.

Create Blender Container clip clip from your project.



Right click the created Media item and select: Edit Container Program
Edit Data

To create the text editor we give following data in the dialog, notice how it
corresponds with the earlier information.

To create the color editor we give following data in the dialog.

Remember to press Add Editor to save given data as an editor.

STEP 3:

SET VALUES FOR TIMELINE CLIPS

Make a Timeline Clip .

Right click the clip and select Container Clip Actions->Edit Container
Program and edit data in the dialog.

LAUNCH SCRIPT

The editors in this example create the code lines below that set attribute
values in the lauch script before render start.

obj = bpy.data.materials["Title1.Material"]

obj.diffuse_color =

0.9882352941176471,0.6862745098039216,0.24313725490196078,1.0

obj = bpy.data.curves["Title1"]

obj.body = "Yesh, this was edited!"

TOOLS

Flowblade provides standalone tools for important functionality that cannot
be logically or conveniently presented via top left panels or the timeline.



Titler
Audio Mixer
Media Relinker
G'Mic Effects
Loading clip and rendering previews
Rendering Output

TITLER

Features:

Add and remove layers in Layers area

Edit layer properties and text in Active Layer area

Set text position by dragging the active layer around in the view editor

Set background image from Timeline to position texts appropriately by
dragging frame pointer in the Position Bar

Load and Save layers data in Layers Area

AUDIO MIXER

Features:

Monitor audio levels on VU meters during playback

Use sliders to set volume for tracks or Master Out

Click Pan button to activate pannig slider and use it to pan audio

MEDIA RELINKER

Media Relinker is a standalone application running in its own process and
does not affect the project that is open in Flowblade

Start by pressing Load Project For Relinking button and select the project
you wish to relink.



Select the media file you wish to replace with some other media file. Press

Set File Relink Path button or press Right Mouse on item to start selecting
the new file. Clips and wipes in the project are linked to this new media file.

Use drop down menu at bottom left to display either missing or found media
files

Press Save Relinked Project As... button to save the relinked version of the
project

Open the relinked project in Flowblade and continue working with it

Media Relinker runs in its own process and does not share state or data with
the running application.

When relinking a project you have open in Flowblade at the same time make
sure that do not overwrite the relinked version of project when saving the
project you have open in Flowblade

G'MIC EFFECTS

G'MIC is a full-featured open-source framework for image processing.

Flowblade G'MIC tool presents user with a selection of commads that can be
used to achieve complex filtering of video clips.

NOTE:

If a command is not present in the system then the corresponding filtering
selection will not work.

Commands are mostly embedded in the /usr/bin/gmic binary itself, so to have
access to more commands you will mostly need to upgrade the binary in your
system.

It is however possible to add and use custom commands and use them for
video filtering, more info here.



LOADING CLIP AND RENDERING PREVIEWS

Start by pressing Load Clip button, and select the video clip you wish to
apply filtering on.

Press on the downward triangle on top of the Script Edit Area on the left
middle of the window to select a gmic command.

You can alter the values given to commands in the Script Edit Area.

Press the Preview button on the right middle to view the filtered image.

After rendering preview the area below Script Edit Area shows text output
from gmic with possible error messages.

You can apply multiple commands by checking Add to script checkbox.

RENDERING OUTPUT

To render a frame sequence you will need to set Mark In and Mark out points
and select a folder to hold the rendered frame sequence.

To render a video file from the filtered frame sequence, check Encode video
checkbox and press the Encoding Settings button to set properties of the
rendered video file.

RENDERING

In Flowblade there are two ways to render output:

Render Panel in the top left notebook in the main window.

Batch Render Queue application that can launched from Render menu.

Almost all the encodings available for FLOSS applications can used in
Flowblade.



Rendering Panel:

Widgets
Rendering output
Batch Render Queue
Adding Items to Batch Render Queue
Using Batch Render Queue application

Rendering behind the scenes:

MLT and libavformat(FFMpeg)
Flowblade rendering pipeline

RENDERING PANEL

WIDGETS

FOLDER SELECT BUTTON

Select folder to place the output file in.

NAME ENTRY WIDGET

Set the name of the output file.

TYPE DROP DOWN MENU

Select between rendering with user defined parameter or use preset render
params and file types.

PRESETS DROP DOWN MENU

Select preset rendering params and file type.

USE PROJECT PROFILE CHECK BOX

Uncheck to select some other then project profile to used for rendered video.



PROFILE DROP DOWN MENU

Select project profile for rendering

ENCODING / FILE TYPE DROP DOWN MENU

Select encoding and container format for rendering.

BITRATE DROP DOWN MENU

Select bitrate for rendering.

RENDER USING ARGS CHECK BOX

Rendering using arguments set in text edit area below.

ARGS TEXT AREA

Set arguments for rendering.

LOAD SELECTION BUTTON

Load rendering arguments defined in left panel into args text area.

EXT ENTRY WIDGET DROP DOWN MENU

Set file extension for args rendered file.

OPEN FILE IN BIN CHECK BOX

Open the rendererd file as media item in current bin.

RENDER RANGE DROP DOWN MENU

Select between rending the complete program or the marked range.

RENDER BUTTON

Renders timeline into a file.



RENDERING OUTPUT

Press Render Button to begin rendering.

A Render Window will open displaying information on file path of render
file, estimated time left, render time and a Progress bar widget.
After rendering is complete, Render Window will close automatically.

BATCH RENDER QUEUE

Flowblade offers a dedicated Batch Render Queue application. Batch Render
Queue is a separate application to Flowblade and runs on different process,
so it is possible to close Flowblade without affecting ongoing renders.

Render queue is a persistent data structure of render items on disk. Each item
consists of a Project file and saved render parameters. Users can add render
items to render queue and then render the whole queue without any further
user input.

ADDING ITEMS TO BATCH RENDER QUEUE

Press To Queue button in Render tab.

Select Render->Add to Batch Render Queue... item from menu

USING BATCH RENDER QUEUE APPLICATION

Open Batch Render Queue application by selecting Render->Batch Render
Queue from menu.

Press Reload Queue button to display render items that have been added to
render queue since it was opened.

Use Delete Selected and Delete Finished buttons to remove items from
queue.

Use checkbox widget in the Render column to select which items will be ren-
dered.

Press Render button to begin rendering.



UI actions:

Right Mouse Click render item to show render item context menu.

Save Item Project As... allows th user to save the Project file of the render
item into same other location

Render Properties displays the render properties that were set when the item
was added to render queue.

Delete deletes the item from queue

RENDERING BEHIND THE SCENES:

MLT AND LIBAVFORMAT(FFMPEG)

Flowblade Movie Editor is a Python application interfacing to MLT
multitrack media framework. Other video editing applications build on top of
MLT include OpenShot and Kdenlive.

MLT uses C-library libavformat(FFMpeg) to render output files, and
rendering is defined by setting FFMpeg encoding parameters. These
parameters are delivered from Flowblade Movie Editor to MLT by creating a
"avformat" Consumer object for a given Render Profile, and then setting its
Rendering Args. These latter arguments are exactly the same which are used
when using FFmpeg to encode video files.

Rendering arguments for encoding different types of video files are
pre-packed and can be selected using Encocing / Format and Quality Drop
Down Menus. Arguments can be refined by checking Render with args
Checkbox and changing args values and/or adding/removing args.

Any kind of video files supported by the installed version of MLT can be
encoded by creating a user defined Render Profile and setting its Rendering
Args. Google for FFMpeg encoding to find Args combinations for different
video files.

Search web for information on encoding files with FFMpeg to get examples
of Rendering Args that can be used.



FLOWBLADE RENDERING PIPELINE

APPENDICES:

Filters list:

FLOWBLADE FILTERS

Alpha
Audio
Audio Filter
Artistic
Blur
Color
Color Effect
Distort
Edge
Fix
Movement
Transform

ALPHA

Filter: Alpha Gradient
Property: Position 0=0.5
Property: Grad width 0=0.5
Property: Tilt 0=0.5
Property: Min 0=0
Property: Max 0=1
Property: Operation 0.0
Filter: Crop
Property: Left 0
Property: Right 0
Property: Top 0
Property: Bottom 0
Property: Blur 0
Property: Invert 1
Filter: Alpha Shape
Property: Shape 0.0
Property: Pos X 0=0.5
Property: Pos Y 0=0.5



Property: Size X 0=0.5
Property: Size Y 0=0.5
Property: Tilt 0=0.5
Property: Trans. Width 0=0.2
Property: Min 0=0
Property: Max 0=1
Property: Operation 0.0
Filter: Alpha Modify
Property: Display 0.0
Property: Display input alpha 0
Property: Operation 0.21
Property: Threshold 0=0.5
Property: Amount 0=0.5
Property: Invert 0
Filter: Color Select
Property: Color #00ff00
Property: Invert 0
Property: Selection subspace 0.0
Property: R/A/Hue 0=0.2
Property: G/B/Chroma 0=0.2
Property: B/I/I 0=0.2
Property: Edge Mode 0.0
Property: Sel. Space exptype=default cbopts=Box:0.0,Ellipsoid:0.5,Dia-
mond:1.0 0.0
Property: Operation 0.0
Filter: Spill Supress
Property: Supress exptype=default cbopts=Green:0.0,Blue:1.0 0.0
Filter: Luma Key
Property: Threshold 128
Property: Slope 0
Property: Pre-Level 0
Property: Post-Level 255
Filter: Chroma Key
Property: Key Color #00ff00
Property: Variance 0.15



AUDIO

Filter: Volume
Property: gain 0=1.0
Property: max_gain 20dB
Property: track 0
Property: end 1
Filter: Pan
Property: Left/Right 0.5
Filter: Pan Keyframed
Property: start 0.5
Property: end 0.5
Filter: Mono to Stereo
Property: Dry/Wet 1
Filter: Swap Channels
AUDIO FILTER
Filter: Pitchshifter - AM
Property: Pitch Shift 1.0
Property: Buffer Size 4
Property: Dry/Wet 1
Filter: Distort - Barry's Satan
Property: Decay Time(samples) 30
Property: Knee Point(dB) -30
Property: Dry/Wet 1
Filter: Frequency Shift - Bode/Moog
Property: Frequency shift 100
Property: Dry/Wet 1
Filter: Equalize - DJ 3-band
Property: Low Gain(dB) 0
Property: Mid Gain(dB) 0
Property: High Gain(dB) 0
Property: Dry/Wet 1
Filter: Flanger - DJ
Property: 0 0.0
Property: Oscillation period(s) 1.0
Property: Oscillation depth(ms) 4.0
Property: Feedback% 0.0
Property: Dry/Wet 1
Filter: Declipper
Property: Dry/Wet 1



Filter: Delayorama
Property: Random seed 0
Property: Input Gain(dB) 0.0
Property: Feedback(%) 0.0
Property: Number of taps 2
Property: First Delay(s) 0.0
Property: Delay Range(s) 6.0
Property: Delay Change 1.0
Property: Delay Random(%) 0.0
Property: Amplitude Change 1.0
Property: Amplitude Random(%) 0.0
Property: 10 1.0
Property: Dry/Wet 1.0
Filter: Distort - Diode Processor
Property: Amount 1.0
Property: Dry/Wet 1.0
Filter: Distort - Foldover
Property: Drive 0.5
Property: Skew 0.5
Property: Dry/Wet 1.0
Filter: Highpass - Butterworth
Property: Cutoff Frequency(Hz) 500
Property: Resonance 0.5
Property: Dry/Wet 1.0
Filter: Lowpass - Butterworth
Property: Cutoff Frequency(Hz) 500
Property: Resonance 0.5
Property: Dry/Wet 1.0
Filter: GSM Simulator
Property: 0 1
Property: Passes 1
Property: Error Rate 0
Property: Dry/Wet 1.0
Filter: Reverb - GVerb
Property: Roomsize 75.75
Property: Reverb time(s) 7.575
Property: Damping 0.5
Property: Input bandwith 0.75
Property: Dry signal level(dB) -70.0
Property: Early reflection level(dB) 0.0



Property: Tail level(dB) -17.5
Property: Dry/Wet 1.0
Filter: Noise Gate
Filter: LF keyfilter(Hz)33.6
Filter: HF keyfilter(Hz)23520.0
Filter: Threshold(dB)-70.0
Filter: Attack(ms)250.0
Filter: Hold(ms)1500.0
Filter: Decay(ms)2000.0
Filter: Range(dB)-90.0
Filter: Bandpass
Property: Center Frequency(Hz) 300.0
Property: Bandwidth(Hz) 300.0
Property: Stages 1
Property: Dry/Wet 1.0
Filter: Pitchscaler - High Quality
Property: Pitch-coefficient 1.0
Property: Dry/Wet 1.0
Filter: Equalize - Multiband
Property: 50Hz gain 0
Property: 100Hz gain 0
Property: 156Hz gain 0
Property: 220Hz gain 0
Property: 311Hz gain 0
Property: 440Hz gain 0
Property: 622Hz gain 0
Property: 880Hz gain 0
Property: 1250Hz gain 0
Property: 1750Hz gain 0
Property: 2500Hz gain 0
Property: 3500Hz gain 0
Property: 5000Hz gain 0
Property: 100000Hz gain 0
Property: 200000Hz gain 0
Property: Dry/Wet 1.0
Filter: Reverb - Plate
Property: Reverb time 4.25
Property: Damping 0.25
Property: Dry/Wet mix 0.66
Property: Dry/Wet 1.0



Filter: Distort - Pointer cast
Property: Effect cutoff(Hz) 500
Property: Dry/Wet mix 0.5
Property: Dry/Wet 1.0
Filter: Rate Shifter
Property: Rate 0.5
Property: Dry/Wet 1.0
Filter: Signal Shifter
Property: Sift 20
Property: Dry/Wet 1.0
Filter: Distort - Sinus Wavewrap
Property: Amount 5.0
Property: Dry/Wet 1.0
Filter: Vinyl Effect
Property: Year 1950
Property: RPM 33
Property: Surface warping 0
Property: Cracle 0
Property: Wear 0
Property: Dry/Wet 1.0
Filter: Chorus - Multivoice
Property: Number of voices 1
Property: Delay base(ms) 10.0
Property: Voice separation(ms) 0.5
Property: Detune(%) 1.0
Property: Oscillation frequency(Hz) 9.0
Property: Output attenuation(dB) 0.0
Property: Dry/Wet 1

ARTISTIC

Filter: Charcoal
Property: X Scatter 2
Property: Y Scatter 2
Property: Scale 1
Property: Mix 1
Property: Invert 0
Filter: Glow
Property: Blur 0.0
Filter: Old Film



Property: Delta 14
Property: Duration 20
Property: Bright. up 20
Property: Bright. down 30
Property: Bright. dur. 70
Property: Develop up 60
Property: Develop down 20
Property: Develop dur. 70
Filter: Scanlines
Filter: Cartoon
Property: Triplevel 0.999
Property: Difference Space 0.004
Filter: Vignette
Property: Aspect 0=0.5
Property: Center Size 0=0.5
Property: Softness 0=0.2
Filter: Emboss
Property: Azimuth 0.2
Property: Lightness 0.33
Property: Bump Height 0.24
Filter: Dither
Property: Levels 0.2
Property: Matrix Type exptype=default cbopts=magic2x2:0.0,mag-
ic4x4:0.12,ordered4x4:0.23,lines4x4:0.34,halftone6x6:0.45,or-
dered6x6:0.56,ordered8x8:0.67,cluster3:0.78,cluster4:0.89,cluster8:1.0 1.0
Filter: Color Halftone
Property: Dot Radius 0.4
Property: Cyan Angle 0.3
Property: Magenta Angle 0.45
Property: Yellow Angle 0.25
Filter: Soft Glow
Property: Blur 0.5
Property: Brightness 0.75
Property: Sharpness 0.85
Property: Blend Type 0.0



BLUR

Filter: Pixelize
Property: Block width 0.1
Property: Block height 0.1
Filter: Blur
Property: Size "0=0.0"
Filter: Grain
Property: Noise 40
Property: Contrast 100
Property: Brightness 85
Filter: IRR Blur
Property: Amount 0.25
Property: Type 0.8
Property: Edge 1
Filter: Box Blur
Property: Amount 5
Property: Horizontal 7
Property: Vertical 7
Filter: RGB Noise
Property: Amount 0.2

COLOR

Filter: Grayscale
Filter: Contrast
Property: Contrast "0=0.5"
Filter: Saturation
Property: Saturation "0=0.125"
Filter: Invert
Filter: Lift Gain Gamma
Property: Lift 0.0
Property: Gain 0.0
Property: Gamma 0.0
Filter: Color Lift Gain Gamma
Property: lift_r 0.0
Property: lift_g 0.0
Property: lift_b 0.0
Property: gamma_r 1.0
Property: gamma_g 1.0



Property: gamma_b 1.0
Property: gain_r 1.0
Property: gain_g 1.0
Property: gain_b 1.0
Property: lift_hue 0.0
Property: lift_value 0.0
Property: gamma_hue 0.0
Property: gamma_value 1.0
Property: gain_hue 0.0
Property: gain_value 1.0
Filter: Hue
Property: Hue 0.0
Filter: Brightness
Property: Brightness 0.5
Filter: Brightness Keyframed
"0=1.0"
Filter: Brightness
Property: level "0=1.0"
Filter: Color Grading
Property: R_table LINEAR
Property: G_table LINEAR
Property: B_table LINEAR
Property: shadow_hue 0.0
Property: mid_hue 0.33
Property: hi_hue 0.66
Property: shadow_saturation 0.5
Property: mid_saturation 0.5
Property: hi_saturation 0.5
Filter: Curves
Property: R_table LINEAR
Property: G_table LINEAR
Property: B_table LINEAR
Property: r_curve 0/0;255/255
Property: g_curve 0/0;255/255
Property: b_curve 0/0;255/255
Property: value_curve 0/0;255/255
Filter: Levels
Property: Channel editor=combobox exptype=default
cbopts=Luma:0.3,Red:0.0,Green:0.1,Blue:0.2 0.3
Property: Show histogram 0



Property: Input black level 0=0
Property: Input white level 0=1
Property: Gamma 0=0.25
Property: Black output 0=0
Property: White output 0=1
Filter: RGB Adjustment
Property: Red 0=0.5
Property: Green 0=0.5
Property: Blue 0=0.5
Property: Action editor=combobox exptype=default cbopts=Add Con-
stant:0.0,Change Gamma:0.5,Multiply:1.0 0.0
Property: Keep Luma 1
Property: Alpha controlled 0
Property: Luma Formula 0.0
Filter: Color Adjustment
Property: R 0=0.5
Property: G 0=0.5
Property: B 0=0.5
Property: hue 0
Property: saturation 0
Property: Luma Band editor=combobox exptype=default cbopts=Shad-
ows:0.0,Midtones:0.5,Highlights:1.0 0.0
Property: Keep luma 1
Property: Alpha controlled 0
Property: Luma formula 0.0
Filter: Gamma
Property: Gamma 1.00
Filter: White Balance
Property: Neutral Color #888888
Property: Color Temperature 0.5

COLOR EFFECT

Filter: Color Clustering
Property: Num 0.5
Property: Dist. weight 0.5
Filter: Chroma Hold
Property: Color #000000
Property: Variance 0.01
Filter: Three Layer



Filter: Threshold0r
Property: Threshold 0=0.5
Filter: Technicolor
Property: Red Saturation 200
Property: Yellow Saturation 200
Filter: Primaries
Property: Factor 32
Filter: Color Distance
Property: Source color #000000
Filter: Threshold
Property: Threshold 125.0
Filter: Posterize
Property: Levels 0.093
Filter: Color Tap
Property: Effect xpro
Filter: Newspaper
Property: Brightness 0.75
Property: Sharpness 0.85
Filter: Sepia
Property: U 75
Property: V 150
Filter: Tint
Property: Black #000000
Property: White #ff8080
Property: Amount 0=0.25
Filter: Colorize
Property: Hue 0.5
Property: Saturation 0.5
Property: Lightness 0.5

DISTORT

Filter: Waves
Property: Amplitude 0.0
Property: Frequency 0.0
Filter: Lens Correction
Property: Rotate 0.5
Property: Tilt 0.5
Property: Center Correct 0.5
Property: Edges Correct 0.5



Filter: Flip
Property: Flip editor=combobox exptype=default cbopts=Horizontal:flip,Ver-
tical:flop flip
Filter: Mirror
Property: Axis editor=combobox exptype=default cbopts=Horizontal:hori-
zontal,Vertical:vertical horizontal
Property: Invert editor=booleancheckbox 0
Filter: V Sync
Property: Position 0.5
Filter: Image Grid
Property: Rows 0.1
Property: Columns 0.1
EDGE
Filter: Edge Glow
Property: Edge Lightning 0.5
Property: Edge Brightness 0.5
Property: Non-Edge Brightness 0.0
Filter: Sobel
FIX
Filter: Denoise
Property: Spatial 0=0.5
Property: Temporal 0=0
Filter: Sharpness
Property: Amount 0=0.5
Property: Size 0=0.5
Filter: Letterbox
Property: Border width 0.2

MOVEMENT

Filter: Baltan
Filter: Vertigo
Property: Phase Incr. 0=0.02
Property: Zoom 0=0.202
Filter: Nervous
Filter: Freeze
Property: Freeze Frame 0
Property: Freeze After 0
Property: Freeze Before 0



TRANSFORM

Filter: Rotate
Property: Angle 0
Property: transition.use_normalised 0
Property: transition.geometry 0=0/0:SCREENSIZE:100
Filter: Shear
Property: Shear X 0
Property: Shear Y 0
Property: transition.geometry 0=0/0:SCREENSIZE:100
Filter: Translate
Property: transition.geometry 0=0/0:SCREENSIZE:100
Filter: Affine
Property: Scale X "0=1.0"
Property: Scale Y "0=1.0"
Property: Shear X 0
Property: Shear Y 0
Property: Angle 0
Property: transition.geometry 0=0/0:SCREENSIZE:100


